分数 20
全屏浏览题目
切换布局
作者 CHEN, Yue
单位 浙江大学
Given two strings S1 and S2, S=S1−S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1−S2 for any given strings. However, it might not be that simple to do it fast.
Input Specification:
Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.
Output Specification:
For each test case, print S1−S2 in one line.
Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.
代码长度限制
16 KB
时间限制
100 ms
内存限制
64 MB
#include<bits/stdc++.h>
using namespace std;
string s,ss,res;
map<char,int>mp;
int main(){
getline(cin,s);
getline(cin,ss);
for(int i=0;i<ss.size();i++)mp[ss[i]]=1;
for(int i=0;i<s.size();i++)
if(!mp[s[i]])res+=s[i];
cout<<res<<endl;
return 0;
}