http://acm.scu.edu.cn/soj/problem.action?id=4438
Censor
frog is now a editor to censor so-called sensitive words (敏感词).
She has a long text pp. Her job is relatively simple -- just to find the first occurence of sensitive word ww and remove it.
frog repeats over and over again. Help her do the tedious work.
Input
The input consists of multiple tests. For each test:
The first line contains 11 string ww. The second line contains 11 string pp.
(1≤length of w,p≤5⋅1061≤length of w,p≤5⋅106, w,pw,p consists of only lowercase letter)
Output
For each test, write 11 string which denotes the censored text.
Sample Input
abcaaabcbcbbbbabcab
Sample Output
aab
非常好的一道题
s数组模拟栈,如果出现敏感词汇,top-= len ,从top开始覆盖
#include <bits/stdc++.h>
using namespace std;
using lon = unsigned long long;const int N = 5e6 + 5;
const lon base = 7;
lon h[N], h_w, h_p[N];
char s[N];
string p, w;
int top = 0;int main()
{h[0] = 1;for(int i = 1; i < N; i++) h[i] = h[i-1] * base;while(cin >> w >> p){h_w = 0; top = 0;for(int i = 0; i < w.length(); i++)h_w = h_w * base + w[i];for(int i = 0; i < p.length(); i++){s[top++] = p[i];h_p[top] = h_p[top-1] * base + p[i];if(top >= w.length() && h_p[top] - h_p[top-w.length()] * h[w.length()] == h_w)top -= w.length();}s[top] = '\0';cout << s << endl;}return 0;
}
/*
abc
aaabcbc
b
bbb
abc
ab*/